Eksperymenty‎ > ‎

Programowanie

Do programowania potrzebujemy język programowania, w którym piszemy program oraz urządzenie, które rozumie ten program i potrafi go wykonać (informatycy mówią o  środowisku do wykonywania programów). 
Środowiskiem do wykonywania programów są komputery i coraz częściej telefony wyposażone w systemy operacyjne (np. Microsoft Windows, Android).
Języków programowania jest bardzo wiele. Do zapoznania się z programowaniem świetnie nadaje się język LOGO albo bazujące na wszystkim znanych klockach LEGO Education.
Program jest to ciąg poleceń w danym języku programowania.

Program w LOGO
W LOGO sterujemy żółwiem, który pozostawia po sobie ślad. W ten sposób możemy rysować różne rzeczy.
Podstawowe polecenia, z których buduje się program w LOGO to:
* naprzód - nakazuje żółwiowi iść do przodu o określoną liczbę kroków, np.: naprzód 10
* prawo -  żółw ma skręcić o określoną liczbę stopni, np.: prawo 90
* powtórz - żółw ma powtórzyć podaną liczbę razy polecenie albo polecenia podane w nawiasie, np.: powtórz 4 [ naprzód 10 prawo 90 ]

Przykładowy program w LOGO
Żółw zaczyna w poniżej pozycji

Po wykonaniu komendy naprzód 2 żółw przesuną się dwa kroki do przodu.

prawo 45

naprzód 2

Po kontynuowaniu i wykonaniu poniższych poleceń dostaniemy narysowany domek.
prawo 90
naprzód 2
prawo 45
naprzód 2
prawo 90
naprzód 4
prawo 90
naprzód 2
prawo 90
naprzód 4

Przykład 2
Powtórzenie trzydzieści sześć razy polecenia naprzód o 10 kroków, a potem skręcenia o 10 stopni daje w efekcie okrąg. 
powtórz 36 [ naprzód 10 prawo 10 ]

Przykład 3
Powtarzając 8 razy program z przykładu 2 rysującego okrąg i skręcają po każdym o 45 stopni otrzymujemy rozetę. 
powtórz 8 [ powtórz 36 [ naprzód 10 prawo 10 ] prawo 45 ]
I ta sama rozeta tyle że pokolorowana.


Więcej o programowaniu w LOGO znajdziecie na przykład w Wikipedii.

LEGO Education
Używając specjalny zestaw klocków lego możemy zbudować roboty. Żeby roboty działały konieczne jest przygotowanie programu, który będzie nimi sterował.

Można na przykład zbudować poniższego aligatora.

Poniższy program spowoduje, jeśli coś włożymy do paszczy krokodyla to on spróbuje to coś złapać. Więc lepiej nie wkładaj tam ręki. ;-)
Ale poważnie. Ten program działa następująco:
- Ikona z klepsydrą oznacza czekanie aż czujnik ruchu zamontowany w paszczy potwora wykryje ruch.
- Jeśli taki ruch się pojawi to uruchamia się silnik sterujący krokodylem i najpierw zamyka, a potem otwiera paszczę, wydając przy tym okropny odgłos (ikonka z nutką).
- Potem program wraca do oczekiwania na kolejny ruch w paszczy.



CoperniKids - eksperymenty dla dzieci z fizyki i innych nauk ścisłych - Warszawa